Version 1.5

Hello all,
I’m happy to announce that version 1.5 is ready. As stated earlier, this version includes an updated script interface with a “set it and forget it” attitude and abilities which you can read about here. The full version changes are here. In addition to the powerful console script, pylinac is now easily installed via conda. All platforms (linux 32/64, osx 64, win 32/64) and all modern python 3 version (3.3, 3.4, 3.5) combinations are supported. You can check out those files here.

Happy coding!

Hi James,

I just tried getting pylinac via conda. After issuing this command:

$ conda install pylinac


I get this annoying message:

FileNotFoundError: [Errno 2] No such file or directory: ‘[redacted]/anaconda3/Scripts/’


output from conda info

$ conda info
Current conda install:

platform : linux-64
conda version : 4.0.5
conda-build version : 1.8.2
python version :
requests version : 2.9.1
root environment : ~/anaconda3 (writable)
default environment : ~/anaconda3
envs directories : ~/anaconda3/envs
package cache : ~/anaconda3/pkgs
channel URLs :
config file : ~/.condarc
is foreign system : False


Any thoughts you might have about why it’s looking for a file and why it might not have it to run it??

PS - I should mention that I installed it via pip (I think !!) last time which meant I had to download and install a few packages separately. This is the first time I’ve tried conda install


Sorry it’s not working for you. I did some digging and it seems that for conda I have to explicitly tell conda what the entry points are when it builds (in addition to pypi). So, conda knows it should look for such a file, but the entry point doesn’t exist because apparently it doesn’t carry over from the file. I’m working on the fix right now and should get a conda bugfix up soon. In the meantime you can still install via pypi and I know the entry points there work. Just make sure you have scikit-image installed first; also remember you need a few additional dependencies installed for the watcher script when installing via pip.

Let me know if you run into any trouble this way. Thanks,


All right, this got a little out of hand (4+ hrs working out the kinks). I added the console scripts to the conda version of pylinac. Additionally, you’ll see the download size is greatly reduced for both conda and pip for the newest version (0.1MB vs 17MB) because I moved the demo datasets outside of the package. Long story short, everything should be good now; upgrade to v1.5.3. Let me know if you run into any other troubles.