Permission denied error

Hello all,

after an attempts to upgrade the pylinac library in our qatrack virtual environment, some permissions were broken and this is the message we are getting, no matter whether we are using pylinac or 2.3.2.

permission error.png

The problem is there is no var/www/.cache folder present. Both /var and var/www are root:root and the permissions for both are set to drwxr-xr-x, however that is exactly what they were before the permission error appeared so that shouldn’t be the issue. Any ideas?


This is more of a QATrack+ issue than Pylinac (mailing list here if you’re not already aware of it).

It’s probably files within the .cache directory that have a permissions issue rather than the directory itself. Usually the issue is the Apache user (usually www-data) doesn’t have read/write permissions on those files.

Likely changing the ownership & permissions of the /var/www/ to www-data like this will fix the problem:

sudo chown -R www-data:www-data /var/www/

sudo chmod -R ug+rwxs /var/www/

then restart Apache. Another approach might be to add www-data to the root group

usermod -aG root www-data

sudo chmod -R ug+rwxs /var/www/

then restart Apache.

Hope that helps!

permission error.png

Hi Randy,

Thanks for your reply. Just tried your first suggestion and it worked!


Στις Τετάρτη, 20 Ιανουαρίου 2021 στις 2:50:03 μ.μ. UTC, ο χρήστης έγραψε: